Skip to main content
Electrolux | Help and Support

Electric Hob Installation Faults

 

Issue
  • The appliance cannot be activated / is not operating.
  • Only two cooking zones light up.
  • Error message E6 or E641 appear on the power setting display.
  • The cooking zones on the left side light up faster and brighter than these on the right.
  • Hob blows / trips fuse
Applies to
  • integrated electric hob
  • freestanding cooker with electric hob
Resolution

In the case of a new installation, the above-mentioned problems usually indicate that the appliance was incorrectly installed.

Note: A new installation means one of the following:

  • A brand new appliance is connected to an electrical supply for the first time.
  • The appliance is connected to a different socket.

1. Check if there is power coming from the socket.

Check whether there is power at the socket by plugging in another appliance and seeing whether that works as it should. If the socket does not work, contact a qualified electrician to help resolve the problem

2. Check the fuse for any possible faults.

Make sure that the fuse is the cause of the malfunction. If the fuse releases again and again, contact a qualified electrician

3. Contact the qualified electrician who installed the appliance.

4. Contact an Authorized Service Centre.

If the above advices do not resolve the problem, we recommend requesting a visit by a service engineer.

NOTE: Depending on the problem, you may be charged for a service visit by an engineer, even during the warranty period.

Warning: We do not recommend using the product until the problem has been completely fixed. Unplug the product and do not plug it in again until you are certain that it is OK to do so. 

 

  • Was this article helpful?